View Single Post
      07-31-2019, 06:47 AM   #57
Joe240
Major
Joe240's Avatar
United_States
2405
Rep
1,265
Posts

Drives: 2020 Z4 M40i
Join Date: Jul 2016
Location: Pensacola

iTrader: (0)

Garage List
2020 Z4 M40i  [0.00]
2019 BMW X3 M40i  [0.00]
Like German1967 said, there's grimlins with every car, particularly within the first production year. Also mentioned, they are mostly software glitches, albeit very minor ones that not everyone seems to have (primarily because we all interface with the car at different levels such as carplay, just BT, no phone connectivity at all, etc.). However, everything within this thread is so minor that it won't affect your driving experience of the car, or it was caused by someone else (my sensor clip being broken for example was from the Dyno technician strapping the car down and not ensuring the strap wasn't snagging anything).

I'll also add that I bought a first year production m240i (2017 model, picked up September 2016). With that, I had the turbo replaced within the first 1500 miles, a coolant line rupture (because the tech who changed the turbo didn't resecure the hose) and a clicking noise in the front driverside wheel hub that turned into a recall and a spacer had to be installed in the hub. So far, I'm at 6500 miles in my Z4 and there have been no major issue REQUIRING service.

The DME recall that they did for me yesterday is not isolated to the z4 either. They did the update on my wife's 2019 X3 m40i when it was in for an oil change a month ago (give or take). I think this is a recall hitting multiple vehicles with the B58 DME and I have no idea what the update was meant to fix.