BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW Z4 Forums (G29) BMW Z4 (G29) General Forum G29 - Trouble / Gremlins / other Issues

Post Reply
 
Thread Tools Search this Thread
      06-14-2019, 11:30 AM   #1
German1967
Lieutenant
German1967's Avatar
United_States
212
Rep
521
Posts

Drives: 2015 M235xi - 2020 Z4 M40i
Join Date: Mar 2015
Location: Ohio

iTrader: (0)

G29 - Trouble / Gremlins / other Issues

I am opening this thread for any issues people encounter to share / seek perspective etc. as more people get access to their Z4s.

Few things I have observed or that have been brought up by others:

- Stones get trapped on M-Brakes
- Wireless charging resulting in overheating of phones under load
- Connected Drive outage (partial / total / delay)
- Comfort Access gremlins: car lights light up when approaching with key even in passing

Feel free to note your observations in this thread.
__________________
Hoc Lapidem Non Vi Sed Saepe Cadendo!
Appreciate 3
      06-14-2019, 02:18 PM   #2
DPelletier
Second Lieutenant
Canada
209
Rep
202
Posts

Drives: 2020 Z4 M40i
Join Date: May 2019
Location: Kelowna, B.C. Canada

iTrader: (0)

I'm hoping this thread doesn't get much action but thanks for posting it.

Dave
Appreciate 3
      06-14-2019, 08:36 PM   #3
CeEl
Captain
United_States
132
Rep
726
Posts

Drives: not too bad
Join Date: Sep 2009
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by German1967 View Post

- Comfort Access gremlins: car lights light up when approaching with key even in passing
I think that one may be a feature. There is a setting to not unlock when approaching, only when door handle (or key fob) is pressed. Or was it the curtesy light? Either way, I am pretty sure there is a setting for that. My genius even mentioned that most people donít like it because lights come on / unlocks even when just walking by in garage.
Appreciate 0
      06-15-2019, 06:18 AM   #4
Jim S
Member
Jim S's Avatar
Scotland
216
Rep
188
Posts

Drives: Z4 M40i G29
Join Date: May 2017
Location: Scotland

iTrader: (0)

Garage List
Quote:
Originally Posted by CeEl View Post
I think that one may be a feature. There is a setting to not unlock when approaching, only when door handle (or key fob) is pressed. Or was it the curtesy light? Either way, I am pretty sure there is a setting for that. My genius even mentioned that most people donít like it because lights come on / unlocks even when just walking by in garage.
I switched off the settings to lock and unlock when approaching or leaving the vicinity of the car. The headlights still come on sometimes when I get near the car when it is locked. I think it might have something to do with the key going to sleep after about 30 seconds. If you then lift the key and go near the car the headlights sometimes, not always, light up.
Very strange, still trying to understand the logic.
Appreciate 0
      06-15-2019, 06:29 AM   #5
Jim S
Member
Jim S's Avatar
Scotland
216
Rep
188
Posts

Drives: Z4 M40i G29
Join Date: May 2017
Location: Scotland

iTrader: (0)

Garage List
Update on the stones getting stuck in the front M Sport brakes.

Since my car was at the dealer for checking out on the ramp with all wheels off I have not had any more occurrences in 400 miles. Good news. I am not sure if the dealer did something with the shields, perhaps bending them out, or the tyres are starting to lose a bit of tackiness and not picking up as many stones. Anyway, time will tell and I will keep the forum updated.
Appreciate 1
      06-15-2019, 07:24 AM   #6
German1967
Lieutenant
German1967's Avatar
United_States
212
Rep
521
Posts

Drives: 2015 M235xi - 2020 Z4 M40i
Join Date: Mar 2015
Location: Ohio

iTrader: (0)

Quote:
Originally Posted by Jim S View Post
Quote:
Originally Posted by CeEl View Post
I think that one may be a feature. There is a setting to not unlock when approaching, only when door handle (or key fob) is pressed. Or was it the curtesy light? Either way, I am pretty sure there is a setting for that. My genius even mentioned that most people don’t like it because lights come on / unlocks even when just walking by in garage.
I switched off the settings to lock and unlock when approaching or leaving the vicinity of the car. The headlights still come on sometimes when I get near the car when it is locked. I think it might have something to do with the key going to sleep after about 30 seconds. If you then lift the key and go near the car the headlights sometimes, not always, light up.
Very strange, still trying to understand the logic.
I have the same experience and believe your assessment is correct. I also switched off lock/unlock when approaching/leaving the car. While I love the concept the execution is painful when the car is parked in the home garage and you walk by several times a day.
__________________
Hoc Lapidem Non Vi Sed Saepe Cadendo!
Appreciate 0
      06-15-2019, 07:54 AM   #7
PrionFawkes
Private
71
Rep
75
Posts

Drives: G29 Z4 M40i (2020)
Join Date: Sep 2018
Location: Chattanooga, TN

iTrader: (0)

Quote:
Originally Posted by German1967 View Post
I have the same experience and believe your assessment is correct. I also switched off lock/unlock when approaching/leaving the car. While I love the concept the execution is painful when the car is parked in the home garage and you walk by several times a day.
Out of curiosity, when say you walk by the car several times a day, do you have the keyfob on you when this occurs?

I always store my wallet and fob when arriving home, and do not pick them up again unless I'm leaving. I'm hoping that practice would prevent the car from constantly preparing for my approach.
Appreciate 0
      06-15-2019, 09:54 AM   #8
rkiger
Registered
3
Rep
4
Posts

Drives: BMW Z4 M40i
Join Date: Jun 2019
Location: Supply, NC

iTrader: (0)

Picked my Z4 M40i up about 2 weeks ago and now have about 480 miles on odometer. Initial thoughts are that is a very nice car and better then the E-89 35i I just turned in. Some gremlins I have experienced in my short two weeks are:
1. Windshield wipers on intermittent speed hop, jump, bounce, stick on windshield. Only when you have a full windshield of water (rain) will the wipers function properly. I've cleaned the windshield and wipers many times with Stoners Invisible Glass cleaner but nothing has help eliminate this condition. Called dealer and they just said to bring it in for them to look. ugh! Especially for a brand new BMW car. Where was quality control when they did their post assembly vehicle check?
2. Yesterday during a 220 mile shake down drive, I noticed the Turn Signal BC button would not switch to the various instrumentation widget clusters i.e. trip data, torque and Horsepower, radio, etc. Only after I stopped the car and turned the engine off would the Turn Signal BC button switch through the various widget options. Hummmmm?
3. General fit and finished not up to previous BMW model standards! i.e. drivers seat thigh support pad does not go back to original position without manually pushing the pad backward. There is a slight gap between the seat and the thigh pad when push backward into its final position.
4. Check your tire inflation when you pick your car up from the dealer. My tires were set to 39 lbs front and 38 lbs rear. According to BMW these should only be 32 lbs both front and rear. I can see increasing the tire pressure if you are on the track, but the car should not be delivered to you with that much air pressure.
Don't mean to be a drag and just complaining about this car but I DO expect better from a BMW vehicle.
Appreciate 0
      06-15-2019, 10:59 AM   #9
Jim S
Member
Jim S's Avatar
Scotland
216
Rep
188
Posts

Drives: Z4 M40i G29
Join Date: May 2017
Location: Scotland

iTrader: (0)

Garage List
Quote:
Originally Posted by rkiger View Post
2. Yesterday during a 220 mile shake down drive, I noticed the Turn Signal BC button would not switch to the various instrumentation widget clusters i.e. trip data, torque and Horsepower, radio, etc. Only after I stopped the car and turned the engine off would the Turn Signal BC button switch through the various widget options. Hummmmm?.
I have experienced this same problem a couple of times. You need to stop and restart the engine to clear the fault.
Appreciate 0
      06-15-2019, 12:12 PM   #10
German1967
Lieutenant
German1967's Avatar
United_States
212
Rep
521
Posts

Drives: 2015 M235xi - 2020 Z4 M40i
Join Date: Mar 2015
Location: Ohio

iTrader: (0)

Quote:
Originally Posted by PrionFawkes View Post
Quote:
Originally Posted by German1967 View Post
I have the same experience and believe your assessment is correct. I also switched off lock/unlock when approaching/leaving the car. While I love the concept the execution is painful when the car is parked in the home garage and you walk by several times a day.
Out of curiosity, when say you walk by the car several times a day, do you have the keyfob on you when this occurs?

I always store my wallet and fob when arriving home, and do not pick them up again unless I'm leaving. I'm hoping that practice would prevent the car from constantly preparing for my approach.
I kept them in my pocket unintentionally. Typically they are stored inside but only a few feet from the vehicle. Hence, occasionally, I walk into the garage with or without keys and the lights will come up. I'd presume if you store the keys with larger distance to the car that should not occur.
__________________
Hoc Lapidem Non Vi Sed Saepe Cadendo!
Appreciate 0
      06-15-2019, 12:20 PM   #11
German1967
Lieutenant
German1967's Avatar
United_States
212
Rep
521
Posts

Drives: 2015 M235xi - 2020 Z4 M40i
Join Date: Mar 2015
Location: Ohio

iTrader: (0)

My general impression is that BMW has significant software issues with iDrive 7 (just read the X5/7 or 3 series fora). We are a bit of a beta tester here with the latest edition of iDrive. Wireless CarPlay integration is finicky and for no reason or pattern will disconnect on occasion. The wireless charging matt (great idea in concept!) runs too hot when used on longer drives when the phone is used in connection with CarPlay/Waze/Nav, forcing you to remove the phone from the charger to avoid overheating. ConnectedDrive does not update for extended periods of time etc etc.

Now the M40i is a great driving car but when you advertise all these electronic features they better work as advertised.

Another thing on mine: I have condensation water in one side mirror (blinker). I read that that could cause the blind spot detection to short out. Hence, I will get that one changed when getting first oil change done.
__________________
Hoc Lapidem Non Vi Sed Saepe Cadendo!
Appreciate 0
      06-15-2019, 02:57 PM   #12
CeEl
Captain
United_States
132
Rep
726
Posts

Drives: not too bad
Join Date: Sep 2009
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by rkiger View Post
Picked my Z4 M40i up about 2 weeks ago and now have about 480 miles on odometer. Initial thoughts are that is a very nice car and better then the E-89 35i I just turned in. Some gremlins I have experienced in my short two weeks are:
1. Windshield wipers on intermittent speed hop, jump, bounce, stick on windshield. Only when you have a full windshield of water (rain) will the wipers function properly. I've cleaned the windshield and wipers many times with Stoners Invisible Glass cleaner but nothing has help eliminate this condition. Called dealer and they just said to bring it in for them to look. ugh! Especially for a brand new BMW car. Where was quality control when they did their post assembly vehicle check?

3. General fit and finished not up to previous BMW model standards! i.e. drivers seat thigh support pad does not go back to original position without manually pushing the pad backward. There is a slight gap between the seat and the thigh pad when push backward into its final position.
Windshield wipers: seems to get better with mileage/use. Itís much less pronounced than it was when I picked the car up.

I am not sure I understand your concern about tight support - that is completely manual, isnít it? I havenít used mine yet, so sorry if thatís a dumb question/statement.
Appreciate 0
      06-15-2019, 03:01 PM   #13
mjohanc
New Member
mjohanc's Avatar
South Africa
6
Rep
7
Posts

Drives: BMW Z4 M40i FE
Join Date: Jun 2019
Location: South Africa

iTrader: (0)

1. Wireless Charging pad packed up about a week after delivery. And now waiting for new part
2. Car has lost all Internet connectivity now for the 3rd time and been back to the dealer twice already... Very unhappy about this! They don't seem to know what the fault is. Network issues or the telematics unit... Don't feel like having my car stripped and taken apart
Appreciate 0
      06-16-2019, 05:26 AM   #14
Jim S
Member
Jim S's Avatar
Scotland
216
Rep
188
Posts

Drives: Z4 M40i G29
Join Date: May 2017
Location: Scotland

iTrader: (0)

Garage List
No big deal but worth mentioning anyway. I have had to replace the battery in both remote controls, one at 5 weeks and the other at 8 weeks. These batteries should last years not weeks. May be dud batteries, time will tell.
Appreciate 0
      06-16-2019, 08:09 PM   #15
tmehanna
Private
21
Rep
79
Posts

Drives: 528i f10
Join Date: Aug 2012
Location: Egypt

iTrader: (0)

Quote:
Originally Posted by German1967 View Post
I have the same experience and believe your assessment is correct. I also switched off lock/unlock when approaching/leaving the car. While I love the concept the execution is painful when the car is parked in the home garage and you walk by several times a day.
Mine hasn't arrived yet but did you guys check for a similar setting for coming/leaving home lights?
Appreciate 0
      06-16-2019, 08:23 PM   #16
nullspace
Private First Class
32
Rep
120
Posts

Drives: 2020 Z4 m40i
Join Date: Sep 2008
Location: Seattle Area

iTrader: (0)

The CarPlay connection is indeed unreliable. It frequently fails to connect.

My connected drive app doesnít work at all. Not sure if itís the car or the server. The weather app doesnít always update properly either.

Otherwise no issues. And these are pretty minor IMO.
Appreciate 0
      06-17-2019, 10:38 AM   #17
rickyr17
New Member
12
Rep
22
Posts

Drives: 2009 BMW Z4 (E89)
Join Date: Feb 2019
Location: Florida

iTrader: (0)

I like the feature

Quote:
Originally Posted by German1967 View Post
I kept them in my pocket unintentionally. Typically they are stored inside but only a few feet from the vehicle. Hence, occasionally, I walk into the garage with or without keys and the lights will come up. I'd presume if you store the keys with larger distance to the car that should not occur.
I keep my keys far enough away that I don't have that problem. I really like when I'm ready to leave my house and go into my garage that the lights come on. Then as I get close to the door, it beeps and unlocks the doors for me. The last finishing touch is the Welcome on the screen. It's as though the car wakes up, unlocks, and says hello when I drive it.
BTW, the Welcome screen is interesting. The name used is tied to the service contract and can only be changed at the dealer. You really should be able to configure it on your own to say whatever you want.
Appreciate 0
      06-17-2019, 11:06 AM   #18
CeEl
Captain
United_States
132
Rep
726
Posts

Drives: not too bad
Join Date: Sep 2009
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by rickyr17 View Post
I keep my keys far enough away that I don't have that problem. I really like when I'm ready to leave my house and go into my garage that the lights come on. Then as I get close to the door, it beeps and unlocks the doors for me. The last finishing touch is the Welcome on the screen. It's as though the car wakes up, unlocks, and says hello when I drive it.
BTW, the Welcome screen is interesting. The name used is tied to the service contract and can only be changed at the dealer. You really should be able to configure it on your own to say whatever you want.
Actually, I think it uses the name you specify in the Online BMW Connected account (you get there through a web browser, not the app). It takes about a day to update in the car. Thatís just the name, not the ďWelcomeĒ greeting.
Appreciate 0
      06-17-2019, 11:49 AM   #19
CeEl
Captain
United_States
132
Rep
726
Posts

Drives: not too bad
Join Date: Sep 2009
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by nullspace View Post
The CarPlay connection is indeed unreliable. It frequently fails to connect.

My connected drive app doesnít work at all. Not sure if itís the car or the server. The weather app doesnít always update properly either.

Otherwise no issues. And these are pretty minor IMO.
I wonder if it is as much (or more so) Apple as it is BMW. I connected my wifeís iPhone (exact same model & software version as mine) to the car as secondary phone, no CarPlay. And it connects just fine every time. Mine is in CarPlay mode and every now and then will not connect (like almost everyone seems to experience from what I read in the forums).

The Connected app has some functions that work quite well (fuel level) and others that donít - it still shows my car at a location where it was about 3 weeks ago. I used to have a picture of a Z4 and now it just shows a car under a cover.
Appreciate 0
      06-17-2019, 12:13 PM   #20
German1967
Lieutenant
German1967's Avatar
United_States
212
Rep
521
Posts

Drives: 2015 M235xi - 2020 Z4 M40i
Join Date: Mar 2015
Location: Ohio

iTrader: (0)

Quote:
Originally Posted by CeEl View Post
Quote:
Originally Posted by nullspace View Post
The CarPlay connection is indeed unreliable. It frequently fails to connect.

My connected drive app doesn’t work at all. Not sure if it’s the car or the server. The weather app doesn’t always update properly either.

Otherwise no issues. And these are pretty minor IMO.
I wonder if it is as much (or more so) Apple as it is BMW. I connected my wife’s iPhone (exact same model & software version as mine) to the car as secondary phone, no CarPlay. And it connects just fine every time. Mine is in CarPlay mode and every now and then will not connect (like almost everyone seems to experience from what I read in the forums).

The Connected app has some functions that work quite well (fuel level) and others that don’t - it still shows my car at a location where it was about 3 weeks ago. I used to have a picture of a Z4 and now it just shows a car under a cover.
I always felt that the Connected App is totally useless and after playing around with it a few times in 2015 (when I got my M235), I forgot about it. Now with the G29 I looked at it again - and - no surprise it is still utterly useless! Thankfully, not a critical tool at all.

CarPlay on the other hand I use all the time. I prefer Waze over the BMW Nav, I use Siri for messaging, I have Apple Music subscription etc.
Annoying enough that BMW enforces a subscription model for CarPlay, but then at least it should work!

Over the last few days and 300 miles with the M40i I love the car's power, aesthetics and feel. CarPlay, however, has been highly unreliable. With iOS 13 Apple will introduce lots of improved capability. I hope eventually BMW will fix the iDrive firmware so we can take full advantage of it.
__________________
Hoc Lapidem Non Vi Sed Saepe Cadendo!
Appreciate 0
      06-17-2019, 03:15 PM   #21
rickyr17
New Member
12
Rep
22
Posts

Drives: 2009 BMW Z4 (E89)
Join Date: Feb 2019
Location: Florida

iTrader: (0)

Quote:
Originally Posted by CeEl View Post
Actually, I think it uses the name you specify in the Online BMW Connected account (you get there through a web browser, not the app). It takes about a day to update in the car. Thatís just the name, not the ďWelcomeĒ greeting.
That's partially correct. It uses the online name but you cannot change that name online. It initially had my full name and I wanted to use my short/nick name instead. I went online and it wouldn't change when I edited it online. I contacted the Genius line and they said I had to go through the dealer because that is tied to the service contract. The dealership eventually fixed it for me.
Appreciate 1
CeEl132.00

      06-18-2019, 12:38 PM   #22
SgtGigglebox
Lieutenant
SgtGigglebox's Avatar
United_States
62
Rep
492
Posts

Drives: '13 Atacama 35is
Join Date: Sep 2012
Location: Washington D.C. Area

iTrader: (0)

Quote:
Originally Posted by rickyr17 View Post
That's partially correct. It uses the online name but you cannot change that name online. It initially had my full name and I wanted to use my short/nick name instead. I went online and it wouldn't change when I edited it online. I contacted the Genius line and they said I had to go through the dealer because that is tied to the service contract. The dealership eventually fixed it for me.
The issue is that the ConnectdDrive backend is kinda wonky/unreliable. You can definitely make the change there, but it doesnt always stick. And even once it does, it might revert back occasionally. Plus it seems to be down roughly 30% of the time that ive tried to access it. That said, you can make the change there.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:30 AM.




bmw
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST