BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW Z4 Forums (G29) BMW Z4 (G29) General Forum G29 - Trouble / Gremlins / other Issues

Post Reply
 
Thread Tools Search this Thread
      02-18-2020, 06:24 PM   #199
Rob_G77
Private
Canada
47
Rep
91
Posts

Drives: 2020 X3 M40i, 2020 Z4 M40i
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

Quote:
Originally Posted by kj57 View Post
Frees up the USB port as well, not sure on the storage limits, took around 20GB without complaining.
I think it's 32GB and there's a way to check the free storage.

For those that say the HK sound system sucks, you might think that just by listening to XM Radio. MP3 sound a whole lot better. I increased BASS by 2 clicks and treble by 1. Sounds ok to me.

Rob
Appreciate 1
SakhirM410204.00

      02-19-2020, 12:36 PM   #200
DrSecretan
New Member
United Kingdom
3
Rep
18
Posts

Drives: BMW Z4 sDrive20i
Join Date: Oct 2019
Location: Glasgow, UK

iTrader: (0)

Quote:
Originally Posted by CeEl View Post
Give the Windows a good cleaning, dry them well after washing (with microfiber cloth).
I tried that and unfortunately it made little difference.

I'm just back from the dealer where they cleaned the seal with some silicone remover then applied some "PF1" lubricant on the seal which seems to have resolved the issue. I looked into it - it seems this stuff has the same part number as "Carbaflo" which some BMW convertible enthusiasts might be familiar with!

They said that the squeak may come back, at which point they would install new seals. Apparently new seals are currently unavailable, so hopefully it doesn't come to that!

I also asked them to look at the plastic trim on the steering wheel which was a little bit creaky when the wheel was pushed and pulled. They used the same lubricant on this and it's also improved substantially.
Appreciate 0
      03-04-2020, 10:09 AM   #201
Josh65
FWTX Z4
United_States
9
Rep
8
Posts

Drives: 2019 BMW Z4 Sdrive 30i (G29)
Join Date: Jul 2019
Location: Fort Worth, TX

iTrader: (0)

Completely Agree

Quote:
Originally Posted by Toejedi View Post
Regards the boot opening triggering the alarm I thought it might be a low key battery so replaced that today but it hasnít resolved it....

Itís deffo the cars software thatís caused this.
I completely agree. It's an issue for sure. I'm hoping for a software update soon to mitigate this issue! Very annoying!
Appreciate 0
      03-09-2020, 10:41 AM   #202
spbbonzo
New Member
12
Rep
24
Posts

Drives: BMW Z4
Join Date: Sep 2019
Location: Midlands

iTrader: (0)

Passenger mirror failure

A week ago I noticed the passenger mirror would stay pushed in until a few seconds had passed. On one occasion it didn't move out at all.

Over the weekend I noticed the mirror didn't auto close when locking the car whereas the driver's side mirror closed without issue.

The mirror is now permanently out and is also not responding to positioning changes from inside the car.

I've booked it into BMW. Has anyone else encountered this?
Appreciate 0
      03-10-2020, 03:17 PM   #203
blaird03
New Member
15
Rep
19
Posts

Drives: M40i, TTS, Abarth
Join Date: Aug 2019
Location: Edinburgh

iTrader: (0)

Quote:
Originally Posted by spbbonzo View Post
A week ago I noticed the passenger mirror would stay pushed in until a few seconds had passed. On one occasion it didn't move out at all.

Over the weekend I noticed the mirror didn't auto close when locking the car whereas the driver's side mirror closed without issue.

The mirror is now permanently out and is also not responding to positioning changes from inside the car.

I've booked it into BMW. Has anyone else encountered this?
This is a known wiring issue - will need a new mirror.
Appreciate 0
      03-12-2020, 09:42 PM   #204
ToysArs
Private
41
Rep
70
Posts

Drives: 2020 Z4 M40i
Join Date: Sep 2019
Location: Lake Forest, CA

iTrader: (0)

My car was serviced today for rear camera recall and they also update idrive to November 2019 version. Aren't idrive updates supposed to be over-the-air? Not sure why I have not received it until today.
Appreciate 0
      03-12-2020, 11:40 PM   #205
Rob_G77
Private
Canada
47
Rep
91
Posts

Drives: 2020 X3 M40i, 2020 Z4 M40i
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

Quote:
Originally Posted by ToysArs View Post
My car was serviced today for rear camera recall and they also update idrive to November 2019 version. Aren't idrive updates supposed to be over-the-air? Not sure why I have not received it until today.
Everyone should have the Nov 2019 update, otherwise the BMW Connected app probably won't work (at all) with the car. I also had to get the dealership to install it because there was never any OTA update showing for me either. Since I've only had the car a month, I think that should have been done during PDI.

Rob
Appreciate 0
      03-13-2020, 05:16 AM   #206
spbbonzo
New Member
12
Rep
24
Posts

Drives: BMW Z4
Join Date: Sep 2019
Location: Midlands

iTrader: (0)

Quote:
Originally Posted by blaird03 View Post
This is a known wiring issue - will need a new mirror.
Thanks for that.

Interestingly, after the mirror staying stuck out for over five days I awoke this morning to find the mirror tucked in. It appears to have done this overnight with no interaction from me.

Bizarre.
Appreciate 0
      03-13-2020, 05:22 AM   #207
spbbonzo
New Member
12
Rep
24
Posts

Drives: BMW Z4
Join Date: Sep 2019
Location: Midlands

iTrader: (0)

Quote:
Originally Posted by spbbonzo View Post
Thanks for that.

Interestingly, after the mirror staying stuck out for over five days I awoke this morning to find the mirror tucked in. It appears to have done this overnight with no interaction from me.

Bizarre.
Now it won't open when driving. Great!

Appreciate 0
      03-19-2020, 09:42 PM   #208
Rob_G77
Private
Canada
47
Rep
91
Posts

Drives: 2020 X3 M40i, 2020 Z4 M40i
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

The rear camera stopped working today. Turning the car off and on did not help. When I opened and closed the rear trunk, then it started working again.

Is there a TSB for camera issues? I've seen mention about this.

Rob
Appreciate 0
      03-24-2020, 11:26 PM   #209
MG 228i
First Lieutenant
141
Rep
330
Posts

Drives: G29 Z4, 340i 6MT, i3s
Join Date: Aug 2014
Location: Los Angeles

iTrader: (0)

Anyone figure out a way to reduce the rattle from the bass?
It sounds like it's coming from the pass-through or speaker panel.

The bass produced by the HK system is not as solid and lacks depth as compared to other BMW models.
__________________
2017 340i - ZMT, ZTR, Z11, Z08
Appreciate 0
      03-25-2020, 02:26 AM   #210
ZedsRedBaby
Major
705
Rep
1,107
Posts

Drives: Z4 M40i
Join Date: Sep 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by MG 228i View Post
Anyone figure out a way to reduce the rattle from the bass?
It sounds like it's coming from the pass-through or speaker panel.

The bass produced by the HK system is not as solid and lacks depth as compared to other BMW models.
Sadly no. Other than turn it down a bit in the dound settings. Ye cannae change the laws of physics.
Appreciate 0
      03-25-2020, 09:00 AM   #211
blaird03
New Member
15
Rep
19
Posts

Drives: M40i, TTS, Abarth
Join Date: Aug 2019
Location: Edinburgh

iTrader: (0)

I filled the pass though hole with an old soft jacket - that helped with the bass vibrations a lot.
Appreciate 0
      03-28-2020, 08:10 AM   #212
spbbonzo
New Member
12
Rep
24
Posts

Drives: BMW Z4
Join Date: Sep 2019
Location: Midlands

iTrader: (0)

Passenger door not opening from inside

A few days after having the passenger side mirror electrics replaced I can no longer open the passenger door from the inside. The open\closed button on the door rises and falls with no issue.

This was working after the mirror fix so:

1) Have I accidentally switched on a child lock option? I can't find any reference to this in the manual. Is there a way of preventing someone from opening the passenger door from the inside?

2) Have BMW knackered something else when fixing the mirror issue?

At the moment I'm opening that the numerous bugs and issues will be fixed on my G29 before the warranty runs out
Appreciate 0
      03-31-2020, 08:19 PM   #213
goat30i
New Member
goat30i's Avatar
14
Rep
10
Posts

Drives: Z4 s30i
Join Date: Feb 2020
Location: Cedar Park TX

iTrader: (0)

Quote:
Originally Posted by goat30i View Post
Just had her delivered from dealer a week ago, and the fabric tension strap (I think that is what it is) that wraps around a rib and should be connected to the top, is disconnected from the top on one side of the car, and is frayed on the other side. With dealer, so not sure what the cause or result is yet, but initial thought may be a new top, which seems drastic.

Also having issue with my phone automatically connecting (using CarPlay) after I added the wife's phone. Have to manually tell it to connect, now--sure this a searchable issue, but haven't yet.

*UPDATE* Dealer ordered new top from Fatherland, top arrived in less than two weeks--Yeah. Dealer scratched and chipped both quarter panels and trunk lid down to bare metal--Boo. Software upgrade fixed lots of little issues (HUD, Maps, CarPlay, Connected App) acting up--Yeah. Back and forth getting paint issues fixed, trim pieces jacked up, rain seal now needs to be replaced again, along with rubber door trims. Swirls in the paint still--Boo.
Appreciate 0
      04-16-2020, 07:52 AM   #214
APDspider
Private
United_States
8
Rep
85
Posts

Drives: 2014 Z4 28i
Join Date: Jul 2010
Location: Palm Beach Gardens, FL

iTrader: (0)

Garage List
Hello from FL,

New owner here, delivery next week. 2019 30i z4 San Fran Red

I had a 2014 Z4 and Iím looking forward to this newer version.

A couple points of observation:

I currently also drive a 2019 Audi A6 Prestige (fully loaded). Originally the Apple CarPlay disconnected and the wireless charging was slow and heated the phone up like crazy. Changing the iOS to 13.x helped with CarPlay and charging. So I believe it could have been an industry wide issue.

Iíll be looking for your issues and hope to remain free of them. Thanks for the good read.
Appreciate 0
      04-16-2020, 06:46 PM   #215
crm834
Registered
0
Rep
1
Posts

Drives: G29-G30-F25-F30
Join Date: Apr 2020
Location: Cairo

iTrader: (0)

Did they fix it for you ?

Quote:
Originally Posted by Josh65 View Post
I've had my Zed for 3 months and I do love it. It does have a lot of bugs - all mentioned here (wireless charge, key fob battery problems, CarPlay wonkyness, etc.).

I've also started having a major upholstery problem. The side bolster on the driver's seat is starting to wear - just from getting in and out of the car. I'm a small guy, but my clothes rubbing on the side bolster are already wearing the leather off. It's disappointing that this is happening so quickly. I'll have the dealer take a look, but I'm afraid this is going to be on ongoing problem. I've started putting my hand against the seat before I sit to try and protect the leather from being rubbed. It's a beautiful car and I hope to keep it that way!

What happened with the dealer ? Did they replace it under warranty ?
I have the same issue
Appreciate 0
      04-17-2020, 10:42 AM   #216
DocWho
Private
DocWho's Avatar
59
Rep
96
Posts

Drives: 2019 X3 30i, 2019 Z4 30i
Join Date: Apr 2019
Location: Georgia, USA

iTrader: (0)

Quote:
Originally Posted by APDspider View Post
Hello from FL,

New owner here, delivery next week. 2019 30i z4 San Fran Red

I had a 2014 Z4 and Iím looking forward to this newer version.

A couple points of observation:

I currently also drive a 2019 Audi A6 Prestige (fully loaded). Originally the Apple CarPlay disconnected and the wireless charging was slow and heated the phone up like crazy. Changing the iOS to 13.x helped with CarPlay and charging. So I believe it could have been an industry wide issue.

Iíll be looking for your issues and hope to remain free of them. Thanks for the good read.
Welcome. I have a 2019 Z4 30i, SF Red, black wheels and trim. Enjoy the car!
Appreciate 0
      04-20-2020, 11:13 PM   #217
goat30i
New Member
goat30i's Avatar
14
Rep
10
Posts

Drives: Z4 s30i
Join Date: Feb 2020
Location: Cedar Park TX

iTrader: (0)

Bubble in dash

Out for a drive this evening, and noticed ~1inch bubble in the passenger side dash. Haven't taken to dealer yet, assume they will have to replace (quick google shows other BMW with similar issue resolved by replacement).



Attached Images
  

Last edited by goat30i; 04-25-2020 at 01:18 PM.. Reason: adding pics
Appreciate 0
      04-25-2020, 05:26 AM   #218
Rob_G77
Private
Canada
47
Rep
91
Posts

Drives: 2020 X3 M40i, 2020 Z4 M40i
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

Quote:
Originally Posted by goat30i View Post
Out for a drive this evening, and noticed ~1inch bubble in the passenger side dash. Haven't taken to dealer yet, assume they will have to replace (quick google shows other BMW with similar issue resolved by replacement).
Can you share a picture of this?

Rob
Appreciate 0
      04-25-2020, 05:31 AM   #219
Rob_G77
Private
Canada
47
Rep
91
Posts

Drives: 2020 X3 M40i, 2020 Z4 M40i
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

One weird issue I have seen on my Z4 is where the washer fluid will temporarily report low on harder braking. I assume there's some kind of float system and the fluid is sloshing around, but my wiper fluid is still full.

Rob
Appreciate 0
      04-25-2020, 01:56 PM   #220
Rob_G77
Private
Canada
47
Rep
91
Posts

Drives: 2020 X3 M40i, 2020 Z4 M40i
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

Quote:
Originally Posted by goat30i View Post
Out for a drive this evening, and noticed ~1inch bubble in the passenger side dash. Haven't taken to dealer yet, assume they will have to replace (quick google shows other BMW with similar issue resolved by replacement).
Oh that sucks! I hope it works out well for you!

Rob
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:54 AM.




bmw
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST