BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW Z4 Forums (G29) BMW Z4 (G29) General Forum New Z4 M40i 'connected' problems

Post Reply
 
Thread Tools Search this Thread
      02-15-2020, 06:42 PM   #1
Rob_G77
Enlisted Member
23
Rep
48
Posts

Drives: 2018 VW Golf R, 2020 BMW Z4
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

New Z4 M40i 'connected' problems

I've never had a car that is so 'connected' before and also one that had so many problems with that, and other things.

The car drives and runs fine, but it's the 'other' things that aren't fine.

- The car doesn't respond to connected app usage. Information is last updated from the day of PDI (3 days ago). I cannot lock, unlock or do anything else with the car and the android phone app. Find my car works though. My phone is a Galaxy S9+ and I don't think it's the phone.

- I phoned BMW Connected support and they had me test the SOS button first to verify the car was connected. The SOS malfunctioned and kept calling BMW after that. Maybe the button is faulty? It finally stopped after 6 or 7 repeated connections.

- Lock when walking away doesn't work all the time. That's a big security issue as far as I am concerned because I cannot trust it to lock by itself.

- With the remote, I unlocked and rolled down the windows while inside a store (testing). I could not roll the windows back up again with the remote.

- When picking up the car, the salesman could not enter the car info into BMW connected. The next day he was able to and texted me. But, of course it doesn't really work.


I see some of these issues may be common for the platform. I have to take it back to the dealership next week to get things sorted out I guess. Otherwise I am happy with the car. It's too cold for top down driving right now in Canada, but the roads are completely clear and dry so I'm going to drive it while I can.

Rob
Appreciate 0
      02-15-2020, 08:26 PM   #2
gasnet
Private First Class
gasnet's Avatar
United_States
43
Rep
165
Posts

Drives: 2020 Z4 M40i
Join Date: Jan 2013
Location: NY

iTrader: (0)

Its not the phone but the carrier. Nfc locked down by carrier. Security concern. Just use card in your wallet if you forget keys. You can still use the app for remote start and unlocking. I cant use Nfc function, i have Verizon. No big deal. I think the dealership set it up wrong for you. As far as duplicating the card key into your phone this will not work, unless you root your phone.
__________________
Garage
2014 Z4 35is RIP /2016 Z4 28i RIP
2015 335i RIP
2016 Audi A7
2018 Genesis G80
Appreciate 0
      02-15-2020, 09:41 PM   #3
Rob_G77
Enlisted Member
23
Rep
48
Posts

Drives: 2018 VW Golf R, 2020 BMW Z4
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

I can't use the app for anything right now because it either doesn't connect to BMW servers or BMW servers cannot connect to the car. I have done the reset by holding the volume down for 30 seconds, but that has not helped.

Another issue I had tonight when backing out of the driveway is the side mirrors point down while backing up. That's a terrible feature when backing out of a garage because you can no longer see the sides of the door entrance. Anyhow, I got out of the garage and started driving - the mirrors stayed pointed down. I had to re-adjust them again. Maybe it happened because I had stopped in the driveway for a bit and they never moved back to original position?

I'll try again tomorrow.

Rob
Appreciate 0
      02-15-2020, 09:47 PM   #4
SakhirM4
Major General
SakhirM4's Avatar
United_States
9999
Rep
8,664
Posts

Drives: '15 SO M4/'20 Z4 M40i
Join Date: Jul 2014
Location: Austin, TX

iTrader: (0)

Garage List
2020 BMW Z4 M40i  [0.00]
2015 BMW M4  [4.38]
Quote:
Originally Posted by Rob_G77 View Post
I can't use the app for anything right now because it either doesn't connect to BMW servers or BMW servers cannot connect to the car. I have done the reset by holding the volume down for 30 seconds, but that has not helped.

Another issue I had tonight when backing out of the driveway is the side mirrors point down while backing up. That's a terrible feature when backing out of a garage because you can no longer see the sides of the door entrance. Anyhow, I got out of the garage and started driving - the mirrors stayed pointed down. I had to re-adjust them again. Maybe it happened because I had stopped in the driveway for a bit and they never moved back to original position?

I'll try again tomorrow.

Rob
It should have been only your passenger side mirror. To avoid the "dip down", slide the mirror switch to the passenger's side
mirror position.
__________________
Tejas Chapter, BMW CCA, mem #23915, President 27 years, www.tejaschapter.org
2015 ///M4, SO/full black, 6MT, HK, light 19"
Appreciate 2
kv198010.50
Zupo10.50

      02-16-2020, 05:31 AM   #5
ZedsRedBaby
Lieutenant
312
Rep
585
Posts

Drives: Z4 M40i
Join Date: Sep 2019
Location: UK

iTrader: (0)

I've had loads of problems like that. It's been better since the dealer updated the software but still not perfect.

On Thursday morning, I left the car parked in the train station car park and walked away. When I turned round to check, it hadn't locked itself so I did it manually. After lunch I checked the app and it said the car was unlocked with the windows open (updated at 12:33).

Fortunately OH was shopping near the station so I asked her to check. The car was locked and the windows closed.

Bit of a waste of space really.
Appreciate 0
      02-16-2020, 10:24 PM   #6
Rob_G77
Enlisted Member
23
Rep
48
Posts

Drives: 2018 VW Golf R, 2020 BMW Z4
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

I tested again tonight and it's now working like it should.

I wish I had an electronic copy of the owners manual. Those are available on the US website, but not the Canada website. My vin unfortunately doesn't work on the US site either

edit:
I just went and searched new Z4 for sale ads. Some have the US VIN. So I used that to get access on the US site. There's way more owner information on the US site than the Canada site. I downloaded a pdf manual.

Rob

Last edited by Rob_G77; 02-16-2020 at 10:30 PM..
Appreciate 0
      02-16-2020, 10:48 PM   #7
SakhirM4
Major General
SakhirM4's Avatar
United_States
9999
Rep
8,664
Posts

Drives: '15 SO M4/'20 Z4 M40i
Join Date: Jul 2014
Location: Austin, TX

iTrader: (0)

Garage List
2020 BMW Z4 M40i  [0.00]
2015 BMW M4  [4.38]
Quote:
Originally Posted by Rob_G77 View Post
I tested again tonight and it's now working like it should.

I wish I had an electronic copy of the owners manual. Those are available on the US website, but not the Canada website. My vin unfortunately doesn't work on the US site either

edit:
I just went and searched new Z4 for sale ads. Some have the US VIN. So I used that to get access on the US site. There's way more owner information on the US site than the Canada site. I downloaded a pdf manual.

Rob
There is an electronic version in your iDrive.
__________________
Tejas Chapter, BMW CCA, mem #23915, President 27 years, www.tejaschapter.org
2015 ///M4, SO/full black, 6MT, HK, light 19"
Appreciate 0
      02-17-2020, 05:51 AM   #8
CeEl
Captain
United_States
151
Rep
775
Posts

Drives: not too bad
Join Date: Sep 2009
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by Rob_G77 View Post
I tested again tonight and it's now working like it should.

I wish I had an electronic copy of the owners manual. Those are available on the US website, but not the Canada website. My vin unfortunately doesn't work on the US site either

edit:
I just went and searched new Z4 for sale ads. Some have the US VIN. So I used that to get access on the US site. There's way more owner information on the US site than the Canada site. I downloaded a pdf manual.

Rob
Driver’s Guide app on your phone or tablet?
Appreciate 0
      02-19-2020, 07:36 PM   #9
Rob_G77
Enlisted Member
23
Rep
48
Posts

Drives: 2018 VW Golf R, 2020 BMW Z4
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

The version of iDrive7 I had was 072019 and the dealership installed 112019 today. That fixes BMW Connected not working.

I also noticed that BMW Connected was having a very high drain on my S9+ battery so I set android to sleep the application as soon as it's in the background.

Rob
Appreciate 1
CeEl151.00

      02-20-2020, 12:09 PM   #10
scampercom
New Member
scampercom's Avatar
7
Rep
14
Posts

Drives: 2018 BMW 230i
Join Date: Aug 2014
Location: Bay Area, California

iTrader: (0)

Garage List
2018 BMW 230i  [0.00]
Semi-related: I thought I read somewhere that iDrive could be updated remotely (a la Tesla, or your phone apps). Are we still having to tromp back to the dealer to do that in 2020? Surprising if so.
Appreciate 0
      02-20-2020, 12:35 PM   #11
Belgian_Bimmer
New Member
Belgium
27
Rep
14
Posts

Drives: Z4 M40i
Join Date: Jan 2020
Location: Belgium

iTrader: (0)

iDrive can be updated remotely if yo have Connected Package, at least over here in EU.
__________________
BMW G29 Z4 M40i - Black-Sapphire Metallic - Vernasca Cognac Seam Grey

Previous: 325i coupé (e36) - 520D (e60) - 530D xDrive (F10)
Appreciate 0
      02-20-2020, 12:36 PM   #12
jeffp1105
Private
United_States
20
Rep
64
Posts

Drives: 2020 Z4 M40i
Join Date: Feb 2014
Location: Colorado

iTrader: (0)

One of the biggest issues I've identified is that if you don't have proper connectivity to the mobile carrier in your country (ATT in the USA), most of these features simply don't work.

In my case, I have no ATT service at my home or in the parking garage. As a result, the features in these locations is completely bricked. This has nothing to do with BMW unless they've messed up the LTE antenna installation.

As a test, find an outdoor location with ROCK SOLID LTE signal from the carrier used in your country. Drive there and wait a few minutes. Go ahead and test. If the problems are location specific, you may have carrier problems.

J
__________________
2020 BMW Z4 M40i, Black/Cognac/799 Black Wheels
Appreciate 0
      02-20-2020, 12:41 PM   #13
Belgian_Bimmer
New Member
Belgium
27
Rep
14
Posts

Drives: Z4 M40i
Join Date: Jan 2020
Location: Belgium

iTrader: (0)

Quote:
Originally Posted by jeffp1105 View Post
One of the biggest issues I've identified is that if you don't have proper connectivity to the mobile carrier in your country (ATT in the USA), most of these features simply don't work.

In my case, I have no ATT service at my home or in the parking garage. As a result, the features in these locations is completely bricked. This has nothing to do with BMW unless they've messed up the LTE antenna installation.

As a test, find an outdoor location with ROCK SOLID LTE signal from the carrier used in your country. Drive there and wait a few minutes. Go ahead and test. If the problems are location specific, you may have carrier problems.

J
True. All of my connected package features, including Active cruise control,... have been out of service for nealy 12 hrs because of connection problems with local carrier.
__________________
BMW G29 Z4 M40i - Black-Sapphire Metallic - Vernasca Cognac Seam Grey

Previous: 325i coupé (e36) - 520D (e60) - 530D xDrive (F10)
Appreciate 0
      02-21-2020, 12:35 AM   #14
Rob_G77
Enlisted Member
23
Rep
48
Posts

Drives: 2018 VW Golf R, 2020 BMW Z4
Join Date: Feb 2020
Location: Regina, SK

iTrader: (0)

Quote:
Originally Posted by Belgian_Bimmer View Post
iDrive can be updated remotely if yo have Connected Package, at least over here in EU.
It also looks like it can be updated from within iDrive itself. I tried that when I got the car, but no update was ever available.

The ATT hotspot cost is also too expensive for Canada and there's no unlimited plan. I need to change my phone plan anyhow and will just continue to use that for data.

Rob
Appreciate 0
      02-21-2020, 05:02 AM   #15
ZedsRedBaby
Lieutenant
312
Rep
585
Posts

Drives: Z4 M40i
Join Date: Sep 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by Rob_G77 View Post
Quote:
Originally Posted by Belgian_Bimmer View Post
iDrive can be updated remotely if yo have Connected Package, at least over here in EU.
It also looks like it can be updated from within iDrive itself. I tried that when I got the car, but no update was ever available.

The ATT hotspot cost is also too expensive for Canada and there's no unlimited plan. I need to change my phone plan anyhow and will just continue to use that for data.

Rob
You can set it in the app to only update when connected to wifi. That downloads the update to your phone. You then need to connect your phone to the car by wifi AND bluetooth to upload the update to the car.
Appreciate 0
      02-22-2020, 07:14 AM   #16
CeEl
Captain
United_States
151
Rep
775
Posts

Drives: not too bad
Join Date: Sep 2009
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by ZedsRedBaby View Post
You can set it in the app to only update when connected to wifi. That downloads the update to your phone. You then need to connect your phone to the car by wifi AND bluetooth to upload the update to the car.
That just doesn’t seem to work in the US. All the features and settings are there, just doesn’t work. Over the air software update doesn’t work either. Had to go to dealer for update. Maybe the 112019 update fixes that. Next oil change is due soon, will ask them to do it then.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:26 PM.




bmw
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST