BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW Z4 Forums (G29) BMW Z4 (G29) General Forum G29 - Trouble / Gremlins / other Issues

Post Reply
 
Thread Tools Search this Thread
      01-17-2020, 04:07 PM   #177
blaird03
New Member
8
Rep
17
Posts

Drives: M40i, TTS, Abarth
Join Date: Aug 2019
Location: Edinburgh

iTrader: (0)

No further forward with the roof/screen creak after visit to the dealers. They cleaned the seals.
I had a z4 as a loaner - which did not have the issue.
Anyone else any progress ?
Appreciate 0
      01-17-2020, 06:00 PM   #178
ZedsRedBaby
Lieutenant
269
Rep
531
Posts

Drives: Z4 M40i
Join Date: Sep 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by blaird03 View Post
No further forward with the roof/screen creak after visit to the dealers. They cleaned the seals.
I had a z4 as a loaner - which did not have the issue.
Anyone else any progress ?
That's disappointing. Had to rearrange mine to next week so I'll let you know. Cleaning the seals definitely helps but I think there's something else going on.

Having said that, I think every vert I've ever owned has had some sort of noise issue when it's cold. At the end of the day, it's not a solid object, it's a bunch of large parts that rest against one another. Just turn up the HK and look forward to getting the top down in the Spring.
Appreciate 0
      01-17-2020, 10:03 PM   #179
kj57
New Member
15
Rep
13
Posts

Drives: BMW Z4
Join Date: Jan 2020
Location: East TN, USA

iTrader: (0)

Had had my alarm go off twice today when opening the trunk with the car locked. Both times after about an hour being locked.

Anyone had any luck with the dealer, tried to reproduce it in may garage but no luck.
Appreciate 0
      01-18-2020, 04:17 AM   #180
Toejedi
New Member
11
Rep
8
Posts

Drives: Z4 G29 M40i
Join Date: Dec 2019
Location: Uk

iTrader: (0)

Regards the boot opening triggering the alarm I thought it might be a low key battery so replaced that today but it hasnít resolved it.

One thing I have noticed is that previously if I accidentally put my key in the boot and closed it the boot wouldnít lock and would beep.... now it doesnít do it and letís you shut the boot. Food job is already unlocked the car beforehand.

This tells me itís the relationship between the key and the car not being correctly recognised which was caused by the software update.

And Iíd also say this is why the comfort follow me home lights and welcome lights no longer come on when approaching a locked car.

Itís deffo the cars software thatís caused this.
Appreciate 1
Josh659.00

      01-18-2020, 04:34 AM   #181
pukeko
New Member
pukeko's Avatar
United_States
12
Rep
6
Posts

Drives: G29 Z4 M40i (2020)
Join Date: Oct 2019
Location: Seattle, WA

iTrader: (0)

For the alarm, it sounds like the issue I had before:

Alarm https://g29.bimmerpost.com/forums/sh....php?t=1629264

My issue was solved after enabling comfort access unlock. Try enabling it if the issue continue.
Appreciate 1
Jim S269.00

      01-20-2020, 05:28 AM   #182
DrSecretan
New Member
United Kingdom
3
Rep
16
Posts

Drives: BMW Z4 sDrive20i
Join Date: Oct 2019
Location: Glasgow, UK

iTrader: (0)

Quote:
Originally Posted by blaird03 View Post
No further forward with the roof/screen creak after visit to the dealers. They cleaned the seals.
I had a z4 as a loaner - which did not have the issue.
Anyone else any progress ?
Good news from me - my dealer completely resolved the roof creak/click noise. I wanted to confirm it was gone before posting so I've been driving around the last few days to test it out and it's all sounding good!

They didn't go into a whole lot of detail on what they did - but they did say that it was related to the windshield-area rather than the roof. Something about some soundproofing material being incorrectly installed at the factory.

They also sorted the doorcard without having to order in another one, and updated my car's software to the November 2019 version. I'm normally not one to speculate on this given it's normally a placebo effect, but I could swear that my speakers sound better after this update!
Appreciate 1
      01-20-2020, 06:40 AM   #183
unstoppable66
New Member
12
Rep
11
Posts

Drives: BMW G29
Join Date: Sep 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by DrSecretan View Post
Quote:
Originally Posted by blaird03 View Post
No further forward with the roof/screen creak after visit to the dealers. They cleaned the seals.
I had a z4 as a loaner - which did not have the issue.
Anyone else any progress ?
Good news from me - my dealer completely resolved the roof creak/click noise. I wanted to confirm it was gone before posting so I've been driving around the last few days to test it out and it's all sounding good!

They didn't go into a whole lot of detail on what they did - but they did say that it was related to the windshield-area rather than the roof. Something about some soundproofing material being incorrectly installed at the factory.

They also sorted the doorcard without having to order in another one, and updated my car's software to the November 2019 version. I'm normally not one to speculate on this given it's normally a placebo effect, but I could swear that my speakers sound better after this update!
Quote:
Originally Posted by DrSecretan View Post
They also sorted the doorcard without having to order in another one, and updated my car's software to the November 2019 version. I'm normally not one to speculate on this given it's normally a placebo effect, but I could swear that my speakers sound better after this update!
I also had this update and I would agree with you, there is definitely a change in the sound. This might be a change in the way the enhanced engine note is piped through the speakers - see my note on my speakers screaming at me, cured by the software update.
Appreciate 0
      01-20-2020, 07:23 AM   #184
spbbonzo
New Member
11
Rep
23
Posts

Drives: BMW Z4
Join Date: Sep 2019
Location: Midlands

iTrader: (0)

Quote:
Originally Posted by unstoppable66 View Post
I also had this update and I would agree with you, there is definitely a change in the sound. This might be a change in the way the enhanced engine note is piped through the speakers - see my note on my speakers screaming at me, cured by the software update.
Yep - the sound is improved with the update and the annoying random low volume on startup issue has also been fixed.

Annoyingly, when playing music off a USB stick the car still fails to continue with the track where it left off on restarting the car.
Appreciate 0
      01-20-2020, 04:11 PM   #185
kj57
New Member
15
Rep
13
Posts

Drives: BMW Z4
Join Date: Jan 2020
Location: East TN, USA

iTrader: (0)

Quote:
Originally Posted by spbbonzo View Post
Annoyingly, when playing music off a USB stick the car still fails to continue with the track where it left off on restarting the car.
I tried several different USB sticks and tried putting the music in folders, then no folders, and still no luck. Not only would it not start where left off but sometimes it would take a while and just say 'USB not recognized' or something like that. Had to unplug and plus the USB back in.

I ended up copying whole USB to the internal HDD, seems to work better like that, at least it plays back where the car was shut off and starts playing quicker. Didnt even realize it had internal storage until I was messing around with settings and found the 'import music data' thing for the USB. Not a good option if you change around songs a lot. Frees up the USB port as well, not sure on the storage limits, took around 20GB without complaining.
Appreciate 0
      01-20-2020, 07:32 PM   #186
ZedsRedBaby
Lieutenant
269
Rep
531
Posts

Drives: Z4 M40i
Join Date: Sep 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by DrSecretan View Post
Good news from me - my dealer completely resolved the roof creak/click noise. I wanted to confirm it was gone before posting so I've been driving around the last few days to test it out and it's all sounding good!

They didn't go into a whole lot of detail on what they did - but they did say that it was related to the windshield-area rather than the roof. Something about some soundproofing material being incorrectly installed at the factory.

They also sorted the doorcard without having to order in another one, and updated my car's software to the November 2019 version. I'm normally not one to speculate on this given it's normally a placebo effect, but I could swear that my speakers sound better after this update!
Thanks for the update. Had to bump mine again due to a work commitment so it's going in next week. I'll share this with them
Appreciate 0
      01-22-2020, 02:30 PM   #187
Toejedi
New Member
11
Rep
8
Posts

Drives: Z4 G29 M40i
Join Date: Dec 2019
Location: Uk

iTrader: (0)

Quote:
Originally Posted by DrSecretan View Post
Good news from me - my dealer completely resolved the roof creak/click noise. I wanted to confirm it was gone before posting so I've been driving around the last few days to test it out and it's all sounding good!

They didn't go into a whole lot of detail on what they did - but they did say that it was related to the windshield-area rather than the roof. Something about some soundproofing material being incorrectly installed at the factory.

They also sorted the doorcard without having to order in another one, and updated my car's software to the November 2019 version. I'm normally not one to speculate on this given it's normally a placebo effect, but I could swear that my speakers sound better after this update!
Fantastic news! Light at the end of the rainbow, itís a pity they couldnít be more precise on the cause but it should be enough for me to explain to my dealer. Time to book it in and get the roof noise fixed!!!
Appreciate 0
      02-01-2020, 08:38 AM   #188
Joe240
Major
Joe240's Avatar
United_States
2276
Rep
1,247
Posts

Drives: 2020 Z4 M40i
Join Date: Jul 2016
Location: Pensacola

iTrader: (0)

Garage List
2020 Z4 M40i  [0.00]
2019 BMW X3 M40i  [0.00]
AC blower started rattling noticeably at low speeds. Dealer ordered the part and will install next week.
Appreciate 0
      02-06-2020, 05:34 AM   #189
justinbsz
New Member
2
Rep
5
Posts

Drives: Z4 M40I 225I
Join Date: Feb 2020
Location: shenzhen

iTrader: (0)

Leaking Transmission

My tranny is Slow dripping oil after 8000KM , My SA said some leaky Gaskets will see once I have time to bring in for full service.
Appreciate 0
      02-06-2020, 06:45 AM   #190
Nharceg
New Member
6
Rep
5
Posts

Drives: BMW Z4
Join Date: Nov 2019
Location: Fort Lauderdale, FL

iTrader: (0)

Is anyone having repeat tire issues? Iím 4K miles in and am replacing the passenger rear tire for the 3rd time now - each time a screw or a nail. I drive the same roads as I did with my 4 series, which never had a flat. Are these tires that much softer?
Appreciate 0
      02-10-2020, 07:23 PM   #191
goat30i
Registered
0
Rep
1
Posts

Drives: Z4 s30i
Join Date: Feb 2020
Location: TX

iTrader: (0)

Tension(?) strap issue

Just had her delivered from dealer a week ago, and the fabric tension strap (I think that is what it is) that wraps around a rib and should be connected to the top, is disconnected from the top on one side of the car, and is frayed on the other side. With dealer, so not sure what the cause or result is yet, but initial thought may be a new top, which seems drastic.

Also having issue with my phone automatically connecting (using CarPlay) after I added the wife's phone. Have to manually tell it to connect, now--sure this a searchable issue, but haven't yet.
Appreciate 0
      02-13-2020, 05:51 AM   #192
DrSecretan
New Member
United Kingdom
3
Rep
16
Posts

Drives: BMW Z4 sDrive20i
Join Date: Oct 2019
Location: Glasgow, UK

iTrader: (0)

Quote:
Originally Posted by goat30i View Post
Just had her delivered from dealer a week ago, and the fabric tension strap (I think that is what it is) that wraps around a rib and should be connected to the top, is disconnected from the top on one side of the car, and is frayed on the other side. With dealer, so not sure what the cause or result is yet, but initial thought may be a new top, which seems drastic.

Also having issue with my phone automatically connecting (using CarPlay) after I added the wife's phone. Have to manually tell it to connect, now--sure this a searchable issue, but haven't yet.
It looks like tension strap problems can lead to a full roof replacement - here's another case which sounds similar: https://www.reddit.com/r/Justrolledi...o_be_replaced/
Appreciate 0
      02-13-2020, 06:14 AM   #193
DrSecretan
New Member
United Kingdom
3
Rep
16
Posts

Drives: BMW Z4 sDrive20i
Join Date: Oct 2019
Location: Glasgow, UK

iTrader: (0)

Has anyone had any problems with their windows squeaking when going up and down? Both my driver and passenger side windows make a loud squeaking noise, especially when it's wet. I've narrowed the issue down to the glass rubbing against the rubber seal at the very bottom of the window seal. The piece is looking a bit rough - like the surface has been abraded where it rubs against the glass - is everyone else's like this?

Here's a video of the problem: https://www.dropbox.com/s/1p9j4p4xtl..._0504.mov?dl=0

And the rubber bit in question: https://www.dropbox.com/s/3tnc7mgf0u...0506.jpeg?dl=0
Appreciate 0
      02-13-2020, 07:27 AM   #194
Joe240
Major
Joe240's Avatar
United_States
2276
Rep
1,247
Posts

Drives: 2020 Z4 M40i
Join Date: Jul 2016
Location: Pensacola

iTrader: (0)

Garage List
2020 Z4 M40i  [0.00]
2019 BMW X3 M40i  [0.00]
Quote:
Originally Posted by DrSecretan View Post
Has anyone had any problems with their windows squeaking when going up and down? Both my driver and passenger side windows make a loud squeaking noise, especially when it's wet. I've narrowed the issue down to the glass rubbing against the rubber seal at the very bottom of the window seal. The piece is looking a bit rough - like the surface has been abraded where it rubs against the glass - is everyone else's like this?

Here's a video of the problem: https://www.dropbox.com/s/1p9j4p4xtl..._0504.mov?dl=0

And the rubber bit in question: https://www.dropbox.com/s/3tnc7mgf0u...0506.jpeg?dl=0
Mine does this as well. Didnít notice it until I had the windows tinted though.
Assumed it was because of tint rubbing against the rubber instead of glass
Appreciate 0
      02-13-2020, 09:10 PM   #195
CeEl
Captain
United_States
151
Rep
771
Posts

Drives: not too bad
Join Date: Sep 2009
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by DrSecretan View Post
Has anyone had any problems with their windows squeaking when going up and down? Both my driver and passenger side windows make a loud squeaking noise, especially when it's wet. I've narrowed the issue down to the glass rubbing against the rubber seal at the very bottom of the window seal. The piece is looking a bit rough - like the surface has been abraded where it rubs against the glass - is everyone else's like this?

Here's a video of the problem: https://www.dropbox.com/s/1p9j4p4xtl..._0504.mov?dl=0

And the rubber bit in question: https://www.dropbox.com/s/3tnc7mgf0u...0506.jpeg?dl=0
Give the Windows a good cleaning, dry them well after washing (with microfiber cloth).
Appreciate 0
      02-17-2020, 06:12 PM   #196
DocWho
Private
DocWho's Avatar
59
Rep
92
Posts

Drives: 2019 X3 30i, 2019 Z4 30i
Join Date: Apr 2019
Location: Georgia, USA

iTrader: (0)

At 645 miles my Z4 has developed a rattle coming from the passenger side door, the front left dash, and a peculiar little chirp about 1 second after I start it that seems to come from the ventilation system. The rattles only happen between 20 and 25 miles per hour. I suspect the passenger side is a door panel. Not sure about the dash or ventilation system. Any ideas?
Appreciate 0
      02-18-2020, 04:19 AM   #197
ZedsRedBaby
Lieutenant
269
Rep
531
Posts

Drives: Z4 M40i
Join Date: Sep 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by DocWho View Post
At 645 miles my Z4 has developed a rattle coming from the passenger side door, the front left dash, and a peculiar little chirp about 1 second after I start it that seems to come from the ventilation system. The rattles only happen between 20 and 25 miles per hour. I suspect the passenger side is a door panel. Not sure about the dash or ventilation system. Any ideas?
The door could be the "door card". A few people have had this including me. Not sure about the others.
Appreciate 1
DocWho58.50

      02-18-2020, 07:33 AM   #198
blaird03
New Member
8
Rep
17
Posts

Drives: M40i, TTS, Abarth
Join Date: Aug 2019
Location: Edinburgh

iTrader: (0)

I had a rattle from the bottom the dash (from new) - under the steering column - was just a loose screen - fixed by dealer
Appreciate 1
DocWho58.50

Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:17 AM.




bmw
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST