BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW Z4 Forums (G29) BMW Z4 (G29) General Forum Z4 M40i logo missing from Instrument Cluster

Post Reply
 
Thread Tools Search this Thread
      07-22-2019, 04:34 PM   #1
J400uk
Enlisted Member
J400uk's Avatar
42
Rep
47
Posts

Drives: G15 840d
Join Date: Dec 2018
Location: London, UK

iTrader: (0)

Z4 M40i logo missing from Instrument Cluster

I've noticed a strange software glitch on my Z4 M40i. When the Instrument Cluster is set to Navigation Map View, the Z4 M40i logo at the top disappears. I'm adamant that it is supposed to be there as it displays when the Navigation Map View is off or when I haven't yet started the car. You can also see it in all the press photos.

Has anyone noticed the same? I've had a look at some pictures online and seems quite random whether it does or doesn't appear

Navigation Map View Enabled = Logo missing


Navigation Map View Off = Logo shows


Ignition Off = Logo always shows



Here are the settings I'm referring to in the iDrive:

Appreciate 0
      07-23-2019, 12:30 PM   #2
Jim S
Member
Jim S's Avatar
Scotland
274
Rep
213
Posts

Drives: Z4 M40i G29
Join Date: May 2017
Location: Scotland

iTrader: (0)

Garage List
I am not sure of exactly what problem you are experiencing but the M40i logo at the top of the main display in my car seems to stay there until I activate the navigation system, at which stage it disappears until I ďStopĒ the navigation system. Hope this helps you.
Appreciate 0
      07-23-2019, 12:48 PM   #3
Jim S
Member
Jim S's Avatar
Scotland
274
Rep
213
Posts

Drives: Z4 M40i G29
Join Date: May 2017
Location: Scotland

iTrader: (0)

Garage List
Had another look at my car. The M40i logo is always present whether or not the box for map display is ticked. It only seems to disappear when I have set the navigation for a destination, as explained in my previous reply.
Appreciate 0
      07-24-2019, 06:58 AM   #4
Mani59
BMW Miniature Collector!
United Kingdom
1619
Rep
6,300
Posts

Drives: E64 630i Sport & E46 330i Inv
Join Date: Nov 2010
Location: Leicestershire

iTrader: (1)

Garage List
Maybe a software reset or update is required at the dealer? Definitely a glitch of some sort.
__________________

My (mainly) BMW gallery: http://jetone.co.uk

Previous : E90 ///M3 | F20 M135i | E63 630i | E65 730d | Plus many 3 and 5er's
Appreciate 0
      07-24-2019, 06:48 PM   #5
GNALUZU
Former BMWCCA/NASA AZ HPDE Instructor
GNALUZU's Avatar
United_States
578
Rep
1,269
Posts

Drives: 2018 M3 CS
Join Date: Jan 2014
Location: Phoenix, AZ

iTrader: (0)

Garage List
2018 M3 CS  [0.00]
Luckily the car comes from the factory with more than enough ///M badges!
__________________
GNALUZU

Retired BMW CCA/NASA HPDE Instructor
Now, just a guy who knows a little bit about a lot of stuff

2018 M3 CS
2020 Z4 M40
Appreciate 1
      07-30-2019, 01:13 PM   #6
JayPichardo
BMW Client Advisor
JayPichardo's Avatar
2911
Rep
2,447
Posts

Drives: 2020 M340i
Join Date: May 2017
Location: Tulley BMW Nashua, NH

iTrader: (0)

Garage List
2020 BMW M340i  [0.00]
Here is the latest software update and it shows the logo.
Attached Images
 
__________________

Contact me for all your BMW needs in the New England area.
Appreciate 0
      07-30-2019, 02:27 PM   #7
J400uk
Enlisted Member
J400uk's Avatar
42
Rep
47
Posts

Drives: G15 840d
Join Date: Dec 2018
Location: London, UK

iTrader: (0)

Quote:
Originally Posted by JayPichardo View Post
Here is the latest software update and it shows the logo.
Thanks that confirms what I thought, as I've seen quite a few online with the logo showing.

How do I get it updated, can it be done over the air? Or does it need to go back to the dealers?
Appreciate 0
      07-31-2019, 12:29 PM   #8
CeEl
Captain
United_States
172
Rep
817
Posts

Drives: not too bad
Join Date: Sep 2009
Location: Chicago, IL

iTrader: (0)

Quote:
Originally Posted by JayPichardo View Post
Here is the latest software update and it shows the logo.
Set a destination in the Navigation ... logo still displayed?
Appreciate 0
      08-10-2019, 07:08 AM   #9
Jim S
Member
Jim S's Avatar
Scotland
274
Rep
213
Posts

Drives: Z4 M40i G29
Join Date: May 2017
Location: Scotland

iTrader: (0)

Garage List
I had the new software installed last week and the M40i logo disappears when I set a destination in the Navigation system.
Appreciate 0
      08-10-2019, 07:30 AM   #10
Jim S
Member
Jim S's Avatar
Scotland
274
Rep
213
Posts

Drives: Z4 M40i G29
Join Date: May 2017
Location: Scotland

iTrader: (0)

Garage List
Quote:
Originally Posted by J400uk View Post
Thanks that confirms what I thought, as I've seen quite a few online with the logo showing.

How do I get it updated, can it be done over the air? Or does it need to go back to the dealers?
I think you need to go to the dealer to get it updated.
Appreciate 1
J400uk42.00

      12-17-2019, 12:03 PM   #11
J400uk
Enlisted Member
J400uk's Avatar
42
Rep
47
Posts

Drives: G15 840d
Join Date: Dec 2018
Location: London, UK

iTrader: (0)

Just to close this thread off, I've now had the software updated and it's solved the problem! The Z4 M40i logo now displays at all times, except when Navigation is running. This seems to be the expected behaviour so all good

Appreciate 0
      12-18-2019, 09:26 AM   #12
spbbonzo
New Member
12
Rep
26
Posts

Drives: BMW Z4
Join Date: Sep 2019
Location: Midlands

iTrader: (0)

The software update appears to have ruined your taste in music though.
Appreciate 4
      12-18-2019, 10:07 AM   #13
ZedsRedBaby
Major
726
Rep
1,144
Posts

Drives: Z4 M40i
Join Date: Sep 2019
Location: UK

iTrader: (0)

Quote:
Originally Posted by spbbonzo View Post
The software update appears to have ruined your taste in music though.
Appreciate 1
SakhirM410237.50

      12-18-2019, 02:36 PM   #14
Keithark
New Member
7
Rep
20
Posts

Drives: Z4 35i M sport
Join Date: Nov 2013
Location: Uk

iTrader: (0)

Quote:
Originally Posted by ZedsRedBaby View Post
Quote:
Originally Posted by spbbonzo View Post
The software update appears to have ruined your taste in music though.
One question, what functionis the picture of the car with the green "assist" light next to it?
Thanks
Appreciate 0
      12-18-2019, 02:55 PM   #15
J400uk
Enlisted Member
J400uk's Avatar
42
Rep
47
Posts

Drives: G15 840d
Join Date: Dec 2018
Location: London, UK

iTrader: (0)

Quote:
Originally Posted by Keithark View Post
One question, what functionis the picture of the car with the green "assist" light next to it?
Thanks
Thatís the adaptive cruise in action! Iíve got the driver assist pack on the car
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:02 PM.




bmw
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST